1919 A4 Forums banner

21 - 28 of 28 Posts

·
Premium Member
Joined
·
5,394 Posts
Are you certain all the semi auto cuts on the internals are correct? Check with them in and the back plate off and see if anything is binding. Make sure the drive rod and spring are not in the bolt when doing this! NEVER stare down the inside of the gun while these are in place.
 

·
Registered
Joined
·
240 Posts
Discussion Starter #22
30calmachinegunner didntje internals so I believe everything is goo there. Breach block works right without cam in play and everything else works as it should with out the breach block in play
 

·
Premium Member
Joined
·
5,394 Posts
I think I see your problem, you have my number so call if you want the help.
 

·
Premium Member
Joined
·
2,557 Posts
Is the modified slot in the Accelerator wide enough to clear the fingers on the front of the semi-trigger?
 

·
Premium Member
Joined
·
5,394 Posts
I spent some time with him on the phone the other day and I am pretty sure it is either the denial island or semi auto mods. It all works until the breech block is installed so I do not think he has enough height in the cuts causing it to bind. I gave him a check list but have not heard back yet.
 

·
Registered
Joined
·
34 Posts
See if you can assemble it with out the breech block pin, it is longer than the width of the bolt in locked position , because the bolt is narrowed up where the pin is at lockup, it needs clearance in the side plate, good luck. Jon P.
 
21 - 28 of 28 Posts
Top