1919 A4 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
This has happened a few times to my gun. I bent it a little to give it more force to stay in the slot but it seems to keep falling out causing problems. Any fixes you know of?

I'm running links BTW

Thanks
 

·
Registered
Joined
·
169 Posts
The only thig that fixed mine was a new spring from OOW.Try cleaning out the slot in the top cover.Sometimes it has some grime in it not letting the spring clip in.
 

·
Registered
Joined
·
346 Posts
The spring's are only $3-$4.I bought five just to keep on hand. I noticed when I got them some looked NOS, some used. get a few.lol
 

·
Registered
Joined
·
864 Posts
That appears to be a common problem. I've bought numerous springs and 3 top covers trying to resolve this problem. 2 out of 3 of the top covers had this problem. Different springs would improve the issue on the 2 top covers that had the problem, but no springs would totally fix it. It appears to be top cover related. Some springs would fall out every 10 rounds. Other springs would fall out about every 300-400 rounds. The only way I totally fixed it was to keep replacing top covers until I found one that would keep the spring secure. I don't know if this has anything to do with it, but the top cover that fixed the issue is the model that has a hole in the top cover that allows you to view the extractor spring notch engagement. The other 2 top covers that had the problem don't have that hole in the top of the cover.
 
1 - 4 of 4 Posts
Top