1919 A4 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
so this happened:



not sure when/how it happened. i just took my DLO out today and loaded up a belt, saw it was all fubar'd. looks like that left side plate rivet somehow sheared off.

not sure what to do about it.

any ideas?
 

·
Registered
Joined
·
4,704 Posts
Knock the rest of the rivets out and re-rivet. At least the broken one. It's in an area that's easily bucked. Nothing in the way.
 

·
PhD in Over-Engineering
Joined
·
12,239 Posts
Definitely harder to replace on an assembled box than on a flat plate before building. However, you just have to get creative in bucking the rivet. Do you have domed rivets on the outside of the LSP, or the earlier flush style? I can send you a couple of rivets, and the tooling you have will dictate what style you do, in addition to what you already have on the three intact rivets. Let me know if you want me to send.

Are you the same prefetch that used to post here back in the "old" days? You may be below the post count were you can send PMs on the new software here. But drop me a line if you want the rivets. rollin13 AT juno DOT com
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
Are you the same prefetch that used to post here back in the "old" days? You may be below the post count were you can send PMs on the new software here. But drop me a line if you want the rivets. rollin13 AT juno DOT com
yep, it's me from way back. joined 1919a4.com in 2006 (but still have FNG status. lol.) i can't pm yet i guess. i'll send you an email. i've got the dome rivets.
 
1 - 4 of 4 Posts
Top